Configure and Verify network types, area types, and router types

Exam: Cisco 300-101 - CCNP Implementing Cisco IP Routing (ROUTE v2.0)


Network Types

There is a choice of configuring the OSPF network type either as broadcast or non-broadcast multi access (NBMA). By using such features, you can configure the broadcast network as NBMA network when the router in the network does not support multicast addressing. Also, NBMA network can be configured as a broadcast network.

Configuration of OSPF Point to Point Network

A point to point network is the simplest network type. As its name describes, it is a link between two points or routers. A packet sent from a router will always have one recipient on the local link.

The configuration steps for point to point network are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Select the interface on the router and enter the interface configuration mode. Ethernet 1/2 represents the interface type.

RouterR1 (config)# interface Ethernet 1/2

Configure the router interface as point to point using ip ospf network command

RouterR1(config-if)# ip ospf network point-to-point

Enter the global configuration mode

RouterR1(config-if)# exit

Configuration of OSPF Point to Multipoint Network

An OSPF point to multipoint interface is defined as the number of point to point interface having one or more neighbors. It can create multiple host routes and is easy to configure as it does not require configuration of neighbors command, no designated router election is required, and consumes only one IP subnet.

The configuration steps for point to multipoint network are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Select the interface on the router and enter the interface configuration mode. Ethernet 2/3 represents the interface type.

RouterR1(config)# interface Ethernet 2/3

Configure the router interface as point to multipoint using ip ospf network command

RouterR1(config-if)# ip ospf network point-to-multipoint

Enter the global configuration mode

RouterR1(config-if)# exit

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 2 represents the process id.

RouterR1(config)# router ospf 2

Configure the router by specifying the network and area id. Address 10.0.0.0 0.0.0.255 represents the network and number 1 represents the area id

RouterR1(config)# network 10.0.0.0 0.0.0.255 area 1

Returns to privileged mode

RouterR1(config)# end

Configuration of OSPF Point to multipoint with Broadcast Network

In broadcast network a single packet transmitted by a device can be multiplied by the medium so that every other end receives a copy. On a multi-access segment OSPF router will elect a designated router (DR) and a backup designated router (BDR) with which all non designated routers will form adjacency.

The configuration steps for point to multipoint with broadcast network are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Select the interface on the router and enter the interface configuration mode. Ethernet 2/5 represents the interface type.

RouterR1(config)# interface Ethernet 2/5

Configure the router interface as point to multipoint for broadcast media using ip ospf network command

RouterR1(config-if)# ip ospf network point-to-multipoint

Enter the global configuration mode

RouterR1(config-if)# exit

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 2 represents the process id.

RouterR1(config)# router ospf 2

Configure the router by specifying the neighbor as an IP address 10.0.1.3 and assigning a cost to neighbor. Number 6 represents the cost assigned to the neighbor.

RouterR1(config)# neighbor 10.0.1.3 cost 6

Returns to privileged mode

RouterR1(config)# end

Configuration of OSPF Point to multipoint with Non Broadcast Network

Non broadcast networks are used to support the frame relay and ATM topology that requires individual permanent virtual circuits to be configured between end points.

The configuration steps for point to multipoint with the non-broadcast network are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Select the interface on the router and enters the interface configuration mode. Ethernet 1/5 represents the interface type.

RouterR1(config)# interface Ethernet 1/5

Configure the router interface as point to multipoint for non-broadcast media using ip ospf network command

RouterR1(config-if)# ip ospf network point-to-multipoint non-broadcast

Enter the global configuration mode

RouterR1(config-if)# exit

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 0 represents the process id.

RouterR1(config)# router ospf 0

Configure the router by specifying the neighbor as an IP 10.0.1.6 and assigning a cost to neighbor. Number 4 represents the cost assigned to the neighbor.

RouterR1(config)# neighbor 10.0.1.6 cost 4

Returns to privileged mode

RouterR1(config)# end

LSA Types

The LSA link-state advertisement is a basic communication media of the OSPF routing protocol that communicates the router’s local routing topology to all other local routers in the same OSPF area. The types of LSA defined in OSPF are:

  • Router LSA (Type1): Describes the link that the router has within a single area and is flooded within an area only.
  • Network LSA (Type 2):  It is created by the designated router (DR) on the subnet, and represents the subnet and the router interface connected to the subnet.
  • Summary LSA (Type 3): Advertise internal networks to routers in other areas. Summary LSA is generated by area border routers (ABR) only.
  • Summary ASBR LSA (Type 4): Advertise an autonomous system boundary router (ASBR) and the cost to reach it. Router trying to reach an external network uses these advertisements to determine the best path to the next hop. It is generated by ABRs.
  • External LSA (Type 5): Redistribute routes from another autonomous system.
  • Group Membership LSA (Type 6): Defined for multicast extensions to OSPF.
  • Not-so-stubby-area (NSSA) LSA (Type 7): Used for carrying external route information within an NSSA.

Area Types

The large OSPF domain is typically broken into different area types to restrict the route propagation and reduce the amount of resource required by each router to maintain its link state database.

  • Backbone Area: A backbone area is responsible for distributing routing information between multiple areas of an autonomous system. Each area is connected to a backbone area. Area 0 is an OSPF backbone area and has reserved area id of 0.0.0.0
  • Transit Area: A transit area is the area having two or more OSPF border routers and is used to pass the traffic from one adjacent area to another. The transit area does not originate this traffic and is not the destination for such traffic.
  • Stub Area: A stub area is an area that does not accept route advertisement or detailed network information external to the area. A stub area typically has only one router that interfaces the area to the rest of the autonomous system.

The configuration steps for configuring stub area are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 5 represents the process id.

RouterR1(config)# router ospf 5

Configure the router by specifying the area id using area command and define the area to be a stub area. Number 10 represents the area id.

RouterR1(config-router)# area 10 stub

Returns to privileged mode

RouterR1(config-router)# end

Not-so-stubby-area (NSSA): A Not-so-stubby-area is similar to stub area. NSSA does not flood type 5 external LSAs from the core into the area, but can import autonomous system external routes in a limited fashion within an area.

The configuration steps for configuring NSSA are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 2 represents the process id.

RouterR1(config)# router ospf 2

Configure the router by specifying the area id using area command and define the area to be a not-so-stubby- area. Number 15 represents the area id.

RouterR1(config-router)# area 15 nssa

Returns to privileged mode

RouterR1(config-router)# end

Totally Stub Area: Like stub area, totally stub area does not receive type 4 or 5 LSAs from their area border routers (ABRs). They also do not receive type 3 LSAs, all routing out of the area relies on the single default route injected by the ABR.

The steps for configuring totally stub area are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 4 represents the process id.

RouterR1(config)# router ospf 4

Configure the router by specifying the area id using area command and define the area to be a totally stub area. Number 12 represents the area id.

RouterR1(config-router)# area 12 stub no-summary

Returns to privileged mode

RouterR1(config-router)# end

Router Types

  • Internal Router: An Internal router is a router having all of its interfaces connected to the same area.
  • Backbone Router: A backbone router is a router having at least one interface must belong to backbone area.
  • Area border router (ABR): An area border router is a router that connects one or more areas and is considered as a member of all areas it is connected to. It keeps multiple copies of link state database in memory.
  • Autonomous system boundary router (ASBR): An ASBR is a router that is connected by using more than one routing protocol and that exchanges route information with the autonomous systems of router. These routers also run an exterior routing protocol and use static routes.

Virtual Link

Virtual links are configured between two routers that have an interface to a single common non-backbone area, also known as transit area. A virtual link is not a physical link; it is a logical link that uses the least path cost between the area border router (ABR) of non-backbone connected area and the backbone ABR of the transit area. A virtual adjacency across the virtual link is formed, and routing information is exchanged.           

The steps for configuring Virtual link are mentioned below:

Enable the privilege mode

RouterR1 > enable

Enter the global configuration mode

RouterR1# config t

Configure the router with OSPF routing process using router ospf command and enter the router configuration mode. Number 110 represents the process id.

RouterR1(config)# router ospf 110

Configure the router using area command to establish virtual link. Number 15 represents area id and number 16 represents router id. 

RouterR1(config-router)# area 15 virtual link 16

Returns to privileged mode

RouterR1(config-router)# end

Verification of OSPF

Once the configuration of OSPF is done, you may face different kind of problems such as; neighborship is not established between routers, or area id mismatch and many more. For that you need to verify OSPF configuration. Use following commands to verify OSPF configuration.

Displays general information about OSPF routing process.

Show ip ospf

Displays the internal OSPF routing table entries to an ABR and ASBR.

Show ip ospf border-router

Displays the list of information related to OSPF database for a specific router.

Show ip ospf database

Displays the list of OSPF LSAs waiting to be flooded over an interface.

Show ip ospf  flood-list

Displays OSPF related interface information

Show ip ospf interface

Displays OSPF neighbor information.

Show ip ospf neighbor

Displays the parameters and the current state of OSPF virtual links.

Show ip ospf virtual-links

Exam Question:

OSPF router uses the concept of areas. What are the characteristics of OSPF area? (choose two)

  1. Area 0 is called the backbone area.
  2. Each OSPF area requires a loopback interface to be configured.
  3. Multiple OSPF areas must connect to area 0.
  4. Single area OSPF networks must be configured in area 1.
  5. Area may be assigned any number from 0 to 65535.

Answer: A, C

Explanation: OSPF is a routing protocol that uses the concept of areas. In OSPF multiple links are connected to backbone area, which are also called area 0.


Related IT Guides

  1. Configure and verify default routing
  2. Configure and verify IPv4 and IPv6 DHCP
  3. Configure and Verify RIPv2
  4. Configure and verify static routing
  5. Describe administrative distance
  6. Describe device security using IOS AAA with TACACS+ and RADIUS
  7. Describe DMVPN (single hub)
  8. Describe IPv6 NAT
  9. Describe, configure, and verify BGP peer relationships and authentication
  10. Explain BGP attributes and best-path selection
  11. Explain Frame Relay
  12. Explain general network challenges
  13. Layer 3 technologies - Describe administrative distance
  14. Use Cisco IOS troubleshooting tools

Autumn Sale! Get 30% Discount on All Your Purchases!

This is a ONE TIME OFFER. You will never see this Again

Instant Discount

30% OFF

Enter Your Email Address to Receive Your 30% OFF Discount Code Plus... Our Exclusive Weekly Deals

A confirmation link will be sent to this email address to verify your login.

* We value your privacy. We will not rent or sell your email address.