Configure and Verify RIPv2

Exam: Cisco 300-101 - CCNP Implementing Cisco IP Routing (ROUTE v2.0)


Overview

The Routing Information Protocol (RIP) is a distance vector, interior gateway routing protocol that uses hop count as a metric for routing IP packets. Hop count is the number of routers that a packet needs to transverse to reach a destination. RIP uses User Datagram Protocol (UDP) for communication. A directly connected RIP network has a metric of zero and an unreachable network has a metric of 16. When RIP is configured, the routers in the network share the entire routing table to its neighbors every 30 seconds.

RIP version 2 (RIPv2) is an improved version of RIPv1. Unlike RIPv1, RIPv2 supports classless routing, Variable Length Subnet Masking (VLSM), and summarization of routes to carry subnet details. You can disable auto-summarization when required. RIPv2 uses multicast communication while RIPv1 uses broadcast communication between routers. You can configure RIPv2 in small and large networks depending on your deployment requirements.

Some of the characteristics of RIPv2 are:

  • Uses multicast routing advertisements
  • Supports classless inter domain routing (CIDR) and VLSM
  • Supports Both plain text and MD5 authentication
  • Uses external route tags

The configuration of RIPv2 is similar to that of the RIPv1, where the only difference is that you need to mention in the configuration that version 2 of RIP will be used for routing.

Consider this example in which a small enterprise network connects its head office (HO) to its Branch office (BO). The HO uses the 192.168.1.0/24 network to manage its premise and the BO uses the 1.1.1.0/24 network. The HO and BO connect each other using 10.10.10.0/32 network.

The summary of steps to configure RIPv2 in this simple network is:

  1. Configure the interfaces in the HO and BO routers.
  2. Configure RIP on both the routers.
  3. Enable RIPv2 on both the routers.
  4. Point the networks that need to be advertised by RIP
  5. Verify configuration and connectivity

Configuring the router interfaces

Use these commands to configure IP addresses to the router interfaces:

HO-Router# configure terminal

HO-Router(config)# interface fa0/0

HO-Router(config-if)# ip address 192.168.1.1 255.255.255.0

HO-Router(config-if)# no shut

HO-Router(config-if)# interface fa0/1

HO-Router(config-if)# ip address 10.10.10.1 255.255.255.0

HO-Router(config-if)# no shut

BO-Router# configure terminal

BO-Router(config)# interface fa0/0

BO-Router(config-if)# ip address 1.1.1.1 255.255.255.0

BO-Router(config-if)# no shut

BO-Router(config-if)# interface fa0/1

BO-Router(config-if)# ip address 10.10.10.2 255.255.255.0

BO-Router(config-if)# no shut

Configuring RIPv2

Use these commands to configure RIPv2:

HO-Router(config)# router rip

HO-Router(config-router)# version 2

BO-Router(config)# router rip

BO-Router(config-router)# version 2

The command router rip directs the router to use RIP. The command version 2 mentions that RIPv2 will be used in the network to exchange routes.

Configuring the networks that need to be advertised

Use these commands to advertise the connected networks to the adjacent routers:

HO-Router(config)# router rip

HO-Router(config-router)# version 2

HO-Router(config-router)# network 192.168.1.0

HO-Router(config-router)# network 10.10.10.0

BO-Router(config)# router rip

BO-Router(config-router)# version 2

BO-Router(config-router)# network 1.1.1.0

BO-Router(config-router)# network 10.10.10.0

The network command points the network that needs to be advertised by RIP.

The sample output of the show running-config command on the routers appears similar to this:

HO-Router# show running-config

...

<Output omitted for brevity>

interface fa0/0

ip address 192.168.1.1 255.255.255.0

no shut

!

!

interface fa0/1

ip address 10.10.10.1 255.255.255.0

no shut

!

!

router rip

version 2

network 192.168.1.0

network 10.10.10.0

...

BO-Router# show running-config

...

<output omitted for brevity>

interface fa0/0

ip address 1.1.1.1 255.255.255.0

no shut

!

!

interface fa0/1

ip address 10.10.10.2 255.255.255.0

no shut

!

!

router rip

version 2

network 1.1.1.0

network 10.10.10.0

...

Verify the configuration and connectivity

Use the show ip route command to verify that HO router has route to BO router and vice versa:

HO-Router#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet0/0

C 10.10.10.0 is directly connected, FastEthernet0/1

R 1.1.1.0/24 [120/1] via 10.10.10.2, 00:00:25, FastEthernet0/1

BO-Router#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 1.1.1.0/24 is directly connected, FastEthernet0/0

C 10.10.10.0 is directly connected, FastEthernet0/1

R 192.168.1.0/24 [120/1] via 10.10.10.1, 00:00:23, FastEthernet0/1

In the sample output, the legend "R" denotes the RIP routes and "C" denotes directly connected networks.

You can also use the ping command to verify end-to-end connectivity:

HO-Router# ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 3 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms

BO-Router# ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms

Exam Question

What is the command that is not used to verify RIPv2 configuration?

  1. show running-config
  2. show ip route
  3. show ip interface brief
  4. ping

Answer: C

The show ip interface brief command cannot be used to verify RIPv2 configuration. This command displays a brief output of the router interfaces and their respective statuses. All other commands mentioned in the question can be used to verify RIP configuration and network connectivity.


Related IT Guides

  1. Configure and verify default routing
  2. Configure and verify IPv4 and IPv6 DHCP
  3. Configure and Verify network types, area types, and router types
  4. Configure and verify static routing
  5. Describe administrative distance
  6. Describe device security using IOS AAA with TACACS+ and RADIUS
  7. Describe DMVPN (single hub)
  8. Describe IPv6 NAT
  9. Describe, configure, and verify BGP peer relationships and authentication
  10. Explain BGP attributes and best-path selection
  11. Explain Frame Relay
  12. Explain general network challenges
  13. Layer 3 technologies - Describe administrative distance
  14. Use Cisco IOS troubleshooting tools

Autumn Sale! Get 30% Discount on All Your Purchases!

This is a ONE TIME OFFER. You will never see this Again

Instant Discount

30% OFF

Enter Your Email Address to Receive Your 30% OFF Discount Code Plus... Our Exclusive Weekly Deals

A confirmation link will be sent to this email address to verify your login.

* We value your privacy. We will not rent or sell your email address.